Wednesday, May 11, 2016

Error when running large report to batch

When one of my users runs a larger report (500k+ lines) to batch, they receive the following error after about 2 hours:

Excel Rendering Extension: Number of rows exceeds the maximum possible in a worksheet of this version. Rows requested: 552994. Maximum rows: 65536.

Not sure why this is happening at this point.  My SysAdmin can run the same report and batch it to the exact same location (C:\Temp on the AOS machine) and it works fine.

I forgot to post the solution here!  Turns out that my user's client was automatically adding a .xls extension to the excel file name for the batch.  Once we changed that to .xlsx, everything worked peachy!


  1. Replies
    1. Thank you for catching this! Oddly enough, this had to do with my user's AX Client automatically giving the excel file a .xls extension instead of .xlsx. Once we ensured the correct extension, it worked. This can also occur if you have an old version of excel on your AOS Batch Server.